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Chapter 1. Developers' Guide

This developers' guide is for:

¥ programmers who want to just use Apache Isis to build applications, and want help setting up
their development environment or to build their code from the command line (eg to execute
within a continuous integration server such as Jenkins)

¥ programmers who want to contribute back patches (bug fixes, new features) either to the
codebase or the frameworkOs documentation

¥ committers of Apache Isis itself who want guidance on release process, publishing documents
and other related procedures.

1.1. Other Guides

Apache Isis documentation is broken out into a number of user, reference and "supporting
procedures" guides.

The user guides available are:

¥ Fundamentals

¥ Wicket viewer

¥ Restful Objects viewer

¥ DataNucleus object store
¥ Security

¥ Testing

¥ Beyond the Basics
The reference guides are:

¥ Annotations

¥ Domain Services

¥ Configuration Properties

¥ Classes, Methods and Schema
¥ Apache Isis Maven plugin

¥ Framework Internal Services
The remaining guides are:

¥ Developers' Guide (this guide)

¥ Committers' Guide (release procedures and related practices)


ugfun.pdf
ugvw.pdf
ugvro.pdf
ugdno.pdf
ugsec.pdf
ugtst.pdf
ugbtb.pdf
rgant.pdf
rgsvc.pdf
rgcfg.pdf
rgcms.pdf
rgmvn.pdf
rgfis.pdf
cgcom.pdf

Chapter 2. Using an IDE

The vast majority of Java developers use an IDE to assist with developing their code, and we highly
recommend that you do like wise as you develop your Apache Isis applications using an IDE.
Apache Isis is built with Maven, and all modern IDEs can import Maven projects.

This chapter shows how to setup and use two of the most popular IDEs, IntelliJ IDEA and Eclipse.

2.1. Developing using IntelliJ IDEA

This material does not constitute an endorsement; JetBrains is not affiliated to
! Apache Software Foundation in any way. JetBrains does however provide
complimentary copies of the IntelliJ IDE to Apache committers.

This section describes how to install and setup JetBrains' IntelliJ IDEA, then how to import an
application into IntelliJ and run it.

2.1.1. Installing and Setting up

This section covers installation and setup. These notes/screenshots were prepared using IntelliJ
Community Edition 14.1.x, but are believed to be compatible with more recent versions/other
editions of the IDE.

Download and Install

Download latest version of IntelliJ Community Edition, and install:

Start the wizard, click through the welcome page:

i} Intelli) IDEA Community Edition Setup - O

Welcome to the IntelliJ IDEA
Community Edition Setup Wizard

This wizard will guide you through the installation of Intelli
IDEA Community Edition.

It is recommended that you close all other applications
before starting Setup. This will make it possible to update
relevant system files without having to reboot your
computer.

Click Mext to continue.

Cancel

s

Figure 1. IntelliJ Installation Wizard - Welcome page

Choose the location to install the IDE:


https://www.jetbrains.com/idea/download/

Choose Install Location

Choose the folder in which to install Intellil IDEA Community
Edition.

Setup will install IntelliJ IDEA Community Edition in the following folder. To install in a
different folder, click Browse and select another folder. Click Next to continue.

Destination Folder

etBrains\Intell] IDEA Community Edition 14.1.1

Space required: 553.6MB
Space available: 30.6GB

Figure 2. IntelliJ Installation Wizard - Choose Location

Adjust any installation options as you prefer:

Installation Options
Configure your Intelli IDEA Community Edition installation

Create associations

[.java

Figure 3. IntelliJ Installation Wizard - Installation Options

and the start menu:



Choose Start Menu Folder

Choose a Start Menu folder for the Intellid IDEA Community
Edition shortcuts.

Select the Start Menu folder in which you would like to create the program's shortcuts. You
can also enter a name to create a new folder.

7-Zip
Accessibility

Accessories

Administrative Tools

Agent Ransack (G64-bit)
Apache Tomcat 7.0 Tomcat?
Atlassian

Beyond Compare 3
ChocolateyGUI

Chrome Apps

Dolby

Dropbox

Figure 4. IntelliJ Installation Wizard - Start Menu Folder

and finish up the wizard:

Completing the IntelliJ IDEA
Community Edition Setup Wizard

Intellid IDEA Community Edition has been installed on your
computer.

Click Finish to close this wizard.

[+[iRun Intglli] IDEA Community Edition;

< Back Cancel

Figure 5. IntelliJ Installation Wizard - Completing the Wizard

Later on weQll specify the Apache Isis/ASF code style settings, so for now select
import settings

| do not want to



)| Complete Installation n

You can import your settings from a previous version of Intellil IDEA.

() I want to import my settings from a custom locatior

Specify config folder or installation home of the previous version of IntelliJ IDEA:
C:\Program Files (x86)\JetBrains\Intelli] IDEA 14.0
i:o:il I do not have a previous version of IntelliJ IDEA or I do not want to import my settings

oK

Figure 6. IntelliJ Installation Wizard - Import Settings

Finally, if you are a trendy hipster, set the Ul theme to Darcula:

Bl Customize IDEA n
UL Themes — Default plugins — Featured plugins
Set UI theme
(®) IntelliJ ) Darcula
module ) [ src ) (€ Helloworld [ module [ src
¥ c* Hellowerld.java x . GH
g E%]:meort javax.swing.*; .
] f—]:i_mport java.awt.*;
|
public class HelloWorld |
£ ©  public HelloWorld() {
g [ ] JFrame frame = new JFrame ("Hello wor
] JLabel label = new JLabel({):
g" lakel.setFont (new Font{"Serif", Font -
- "
1abeld | Breakpaints :
frame J
frame d + — a B
frame d

framel | B [ @ Line Breakpoints
frame | I Line 6 in HelloWorld.Hello
& } B[] @ Exception Breakpoints

(] any exception

[+ public sta

UI theme can be changed later in Settings | Appearance & Behavior | Appearance

Skip All and Set Defaults Next: Default plugins

Figure 7. IntelliJ Installation Wizard Set Ul Theme

New Project

In IntelliJ a project can contain multiple modules; these need not be physically located together. (If
you are previously an Eclipse user, you can think of it as similar to an Eclipse workspace).

Start off by creating a new project:



P |

Intellid IDEA

Version 14.1.1

% Create New Project [/\\3

ICd Import Project
1 Open

¥ Check out from Version Control +

4 Configure ~ Get Help +

Figure 8. IntelliJ Create New Project

We want to create a new Java project:

Project SDK: | <None>

“# Android

B3 Java FX Additional Libraries and Frameworks:

1 Intelli) Platform Plugin SDK
“# Android SDK

% Intelli) Platform Plugin

m Maven

& Gradle

© Groowy
@ Griffon

2 Empty Project

Use library: | [No library selected]

Error: library is not specified

(v | N [(concet | [ hep |

Figure 9. IntelliJ Create New Project - Create a Java project

We therefore need to specify the JDK. Apache Isis supports both Java 7 and Java 8.



ASIIEG EBX O &+ Hide path
C\Program Files\Java\jdk1.7.0_45

» [ glassfish-4.0
[ Greenshot

B HP [%
s
1 11S Express

[ intel
3 Internet Explorer

[ jdk1.8.
» [jdk1.8.0_11
» Bjre7
» Cjres

Drag and drop 2 file inte the space above to quickly locate it in the tree.

Figure 10. IntelliJ Create New Java Project - Select the JDK

Specify the directory containing the JDK:

Project name: | dev

Project 1ocation:| C:\intellijprojects\dev{

N

* Mare Settings

v (D (o ] e

Figure 11. IntelliJ Create New Project - Select the JDK location

Finally allow IntelliJ to create the directory for the new project:



bl Directory Does Not Exist n

The project file directory
"C\intellijprojects\dev”
does not exist. It will be created by Intelli) IDEA.

Figure 12. IntelliJ Create New Project

File templates

Next we recommend you import a set of standard file templates. These are used to create new

classes or supporting files:

|5/=8 Edit View Mavigate Code Analyze Refactor Build Run Tools VCS Window |

3 Open... Project from Existing Sources...
Open Recent » Project from Version Contral [
Close Project Module...

¥ Settings... Ctrl+Alt+5 Module from Existing Sources...

[ Project Structure... Ctrl+Alt+Shift+5 (© Java Class

Other Settings

Import Settings...
Export Settings...
Settings Repository...
= Save All
@ Synchronize
Invalidate Caches / Restart...
Export to HTML...
= Print...
Add to Favorites
File Encoding
Line Separators
Make File Read-only

Power Save Mode

Exit
L Ldryer

B datanucdleus.log

[t logd) properties

Figure 13. File templates

The file templates are provided as a settings JAR file, namely

Download this file.

Next, import using File > Import Settings

file to:

* [% Kotlin File/Class
B Fie
B8 Bash Script
[E3 Package

Ctri+S E package-infojava
Ctri+Alt+Y [E HTML File

fl Apache Isis Domain Entity
i Apache lsis Domain Mixin
fil Apache lsis Domain Service (Menu)

il Apache Isis Domain Service (Repository)

-

i Apache |sis Domain Service (Subscriber)
fil Apache lsis Fixture (Create)
i Apache lsis Fixture (Rowhandler)

-

il Apache lsis Fixture (Teardown)
i Apache lsis View Model (JAXE)
| Apache lsis View Model {regular)

il Singleton

F_'; Apache lsis Domain Object Layout (XML)

isis-settings-file-templates.jar

, specifying the directory that you have downloaded the


resources/appendices/dev-env/intellij/isis-settings-file-templates.jar

L) Import File Location

Select the settings file to import or directory where the file is located

achHEOQ BX O & Hide path
| Ch\Users\Dan\Downloads\settings |ﬁ

il isis-settings-code-stylejar

: isis-settings-file-templates.jar

: isis-settings-live-templates.jar

—

Drag and drop z file into the spac

Figure 14. IntelliJ Import Settings - Specify JAR file

Select all the categories (there should just be one), and hit OK. then hit restart.

Apparently no categories are shown if importing into IntelliJ 2016.1.1 Community
Edition (and perhaps other 2016 versions). The file does import ok into IntelliJ
15.0.%, so we think this is a bug in the 2016 version.

The workaround is to extract the  .jar file locally and copy the files into IntelliJOs
config directory, somewhere in your home directory:

¥ Windows <User home>\.IdealC2016\config
¥ Linux ~/..ldealC2016/config
¥ Mac OS ~/Library/Preferences/IdealC2016

Live templates

We also recommend you import a set of live templates. These are used to add new methods to
existing classes:

public class CustomerOrder implements Comparable<CustomerOrder> {

i
isc-jdo-1m-b-fk Apache Isis Collection (JDO, 1:m parent bidirectional to foreign key) -
isobj-events Apache Isis Object: abstract domain events declarations
isp-jdo Apache Isis Property (JDO)
isa Apache Isis Action
isa-dis Apache Isis Action disablement
isa-event Apache Isis Action (with domain event)
isa-event-decl Apache Isis Action (domain event declaration only)
isa-hid Apache Isis Action visibility
isa-p-auto Apache Isis Action parameter auto-complete
isa-p-cho Apache Isis Action parameter choices
isa-p-def Apache Isis Action parameter defaults
isa-p-val Apache Isis Action parameter validation
isa-val Apache Isis Action validation
isc-dis Apache Isis Collection disablement
isc-event-decl Apache Isis Collection (domain event declaration only)
isc-hid Apache Isis Collection wisibility
isc-jdo-1m-b-jt Apache Isis Collection (JDO, 1:m parent bidirectional to join table)
isc-jdo-1m-u-fk Apache Isis JDO Collection (1l:m parent unidirectional)
isc-jdo-1m-u-jt Apache Isis Collection (JDO, 1:m parent unidirectional to join table)
isc-jdo-mn-ub-c Apache Isis Collection (JDO, m:n child)
Ctrl+Down and Ctrl+Up will move caret down and up in the editor >> T

Figure 15. Live templates



The live templates have a prefix of prefixed either:

¥ is : for Apache Isis domain objects

¥ ju : for JUnit tests

¥ jm : for IMock mocks or libraries

¥ ad: for Asciidoc documentation; a full list can be found in the appendix .

The live templates are also provided as a settings JAR file, namely isis-settings-live-templates.jar
Download and import (as for the previous settings JAR files).

Coding Standards

Next, we suggest you recommend you import settings for standard ASF/Apache Isis coding
conventions. This file is also provided as a settings file, namely isis-settings-code-style.jar
Download and import (as for the above settings JAR files).

Other Settings (Compiler)

There are also some other settings that influence the compiler. We highly recommend you set
these.

On the Compiler Settings page, ensure that build automatically  is enabled (and optionally compile
independent modules in parallel ):

| Settings n

(Q ) Build, Execution, Deployment > Compiler = For current project Reset
Appearance & Behavior Resource patterns: | 12 java;!?* form;17% class;17*.groovy;1 7% scala;17* flex;| 2% kil 7%.clj;17%.a | ®
Keymap Use ; to separate patterns and ! to negate a pattern. Accepted wildcards: ? — exactly one symbol; * — zero or
Editor more symbols; / — path separator; /**/ — any number of directories; <dir_name=>:<pattern> — restrict to

. source roots with the specified name
Plugins

v . .
Version Control B4 Clear output directory on rebuild

Build, Execution, Deployment Add @NotMNull assertions

Build Tools Automatically show first error in editor
Maven Display notification on build completion
Gradle Make project automatically (only works while not running / debugging)
Gant
— - . . .
E4 Compile independent modules in parallel (may require larger heap size)
Excludes Rebuild module on dependency change
Java Compiler Build process heap size (Mbytes): 700
Annotation Processors - - -
o Additional build process VM options: |
Validation
RMI Compiler

Groowvy Compiler
Gradle-Android Compiler
Android Compilers

i}

Coverage
Debugger
Path Variables

“ I Cancel ‘ I Apply ‘ I Help ‘

Figure 16. IntelliJ Compiler Settings

On the Annotation Processors  page, enable and adjust for the 'default’ setting:

10


resources/appendices/dev-env/intellij/isis-settings-live-templates.jar
resources/appendices/dev-env/intellij/isis-settings-code-style.jar

Groovy Compiler
Coverage
Debugger
Path Variables
Languages & Frameworks
Tools
Other Settings

% simpleapp-fixture

3 simpleapp-integtests

[ simpleapp-webapp
Maven default annotation processors profile
Annotation profile for asdidoctor-maven-plugin

Annotation profile for estatio-dom

I settings x
@ ) Build, E Deployment > Compiler : A P T @ T
Editor + — # Enable annotation processing
mve Spas
¥ Default
Fie Types © Obtai processors from profect casspath
Copyright Cadev
Emmet Caisis O Processor path: ‘ ‘ s
3 isis-app-kitchensink
meszs Store generated sources relative to: O Module output directary © Module content root
Intentions & isis-app-kitchensink-app
Language Injections i isis-app-kitchensink-dom Production sources directory: ‘ target/generated-sources/annotations ‘
Speling 3 isis-app-kitchensink-fixture
555 & isis-app-kitchensink-integtests Test sources directory: ‘ target/generated-test-sources/test-annotations ‘
Plugins Lasis-app-kitchensink-webapp Annotation Processors
= 3 isis-core-security
[eneacente e Processor FQ Name =+
Build, Execution, Deployment ® isis-documentation
Build Tools 3 isis-viewer-wicket-applib R S
Compiler Ca isis-viewer-wicket-impl i o :
Excludes 3 isis-viewer-wicket-model
Java Compiler 3 isis-viewer-wicket-ui
S Amotation rocessor options
& simpleapp-app
VElEEEET Option Name Value +
RMI Compiler [ simpleapp-dom

WARNING!

ies where

If option 'Clear output directory on rebuild’ is bled, the entire

sources are stored WILL BE CLEARED on rebuild.

G

K8 (=) ) (=)

Figure 17. IntelliJ Annotation Processor Settings

This setting enables the generation of the
being required for frameworks such as Project Lombok .

IntelliJ may also have inferred these settings for specific projects/modules when
| importing; review the list on the left to see if the default is overridden and
fix/delete as required.

Other Settings (Maven)

There are also some other settings for Maven that we recommend you adjust (though these are less

Q* classes for DataNucleus type-safe queries, as well as

critical):

First, specify an up-to-date Maven installation, using

on MacOS):

File > Settings

(or Intellid > Preferences if

11



(C’\ maven Q)

7 Appearance & Behavior
Notifications
Keymap
7 Editor
Inspections
File and Code Templates
Live Templates

Plugins
7 Build, Execution, Deployment
7 Build Tools
WEEY
Importing
Ignored Files
Runner
Running Tests
Repositaries

Build, Execution, Deployment > Build Tools » Maven = For current project

[ Work offline

[J Use plugin registry
Execute goals recursively
[ Print exception stack traces
[ Always update snapshots

QOutput level: Info
Checksum policy: No Global Policy [
Multiproject build fail policy: A
Plugin update policy: A

Threads (-7 oprion):

ignored by Maven 3+

Maven home directory: Bundled (Maven 3)

Bundled (Maven 2}
Bundled (Maven 3)

User settings file:

C:/binfapache-maven-3.2.3
CAUsers\Dan\.m2\repository

Local repository:

- L] Override

Figure 18. IntelliJ Maven Settings - Installation

Still on the Maven settings page, configure as follows:

12
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N Settings n

(Q ) Build, Execution, Deployment  Build Tools » Maven > Importing © For current project Reset
Appearance & Behavior
Keymap [[] Keep project files in: |
Editor
Plugins Import Maven projects automatically
Version Control Create Intelli) IDEA modules for aggregator projects (with '‘pom’ packaging)
Build, Execution, Deployment Create module groups for multi-module Maven projects
Build Tools
Maven Keep source and test folders on reimport

Importing Exclude build directory (%PROJECT_ROOT%/target)

Ignored Files Use Maven gutput directories
Runner

Generated sources folders: [Detect automatically [k -

Phase to be used for folders update: hd

Running Tests

Repositories

Gradle
Gant IDEA needs to execute one of the listed phases in order to discover all source folders that are configured via Maven plugins.
. Note that all test-* phases firstly generate and compile production sources.
Compiler
Coverage Automatically download: [] Sources [] Documentation
Debugger

Dependency types: | jar, test-jar, maven-plugin, ejb, ejb-client, jboss-har, jboss-sar, war, ear, bundle
Path Variables

Languages & Frameworks

Comma separated list of dependency types that should be imported

Tools WM options for impor‘ter:| -Xmx312m
Other Settings

DK for \'mporter:‘ E2 Use Internal JRE (java version "1.8.0_40", path: C:/Program Files (x86)/Je..unity Edition 14.1.1/jre/jre) n

Co iy

Figure 19. IntelliJ Maven Settings - Configuration

Other Settings (Misc)

These settings are optional but also recommended.

On the auto import  page, check the optimize imports on the fly and add unambiguous imports on
the fly

13




bl Settings H

(Q ) Editor : General > Auto Import Reset
Appearance & Behavior WML
Keyma
ymap Show import popup
Editor
General Java
Smart K
IR L Insert imports on paste: v
Appearance
Editor Tabs Show import popup
Code Folding Optimize imports on the fly
Code Completion Add unambiguous imports on the fly

Auto Import .
Exclude from Import and Completion

Postfix Completion
Console Folding
Colors & Fonts

Code Style exclude patterns
Java
Groovy
HTML
JSON
Properties
XML
Inspections [%

File and Code Templates
File Encodings

- S Py

o Jreiyen iy

Figure 20. IntelliJ Maven Settings - Auto Import

2.1.2. Importing Maven Modules

LetOs load in some actual code! We do this by importing the Maven modules.

First up, open up the Maven tool window ( View > Tool Windows > Maven Projects ). You can then use
the 'plus' button to add Maven modules. In the screenshot you can see weOve loaded in Apache Isis
core; the modules are listed in the  Maven Projects window and corresponding (IntelliJ) modules are
shown in the Projects window:

14



Fle Edt View Navigate Code Anabze Refactor Build Run Tools VCs Window Help

DHG ¢4 X000 QR ¢ HEIPE@mMY @ F@ ? <
& Add Maven Projects | Lt
v core [sis] (CAAPACHEss-gitr PEE DR 3
» [3applib [isis-core-applib] g Profiles H
» [ fakedata T Apache Isis Care (root)
s i
2 rG - N T Isis Core (Bypass) Security
S|+ alogsj lisis-core-logdj] 7 sis Core AppLib
| » [amaven-plugin [isis-maven-plugin] 7 Isis Core Integration Testing Support
» [ metamodel [isis-core-metamodel] 7 Isis Core Log4j Impls
» [ abjectstore-inmemory [ Isis Core MetaModel
» L runtime [lslsw_r?—mmlme] . ) Isis Core RestfulObjects Viewer Applib
» E3 security-noop [isis-core-security] [, Isis Core RestfulObjects Viewer Rendering
» [ security-shiro [sis-core-security-shiro] 7 Isis Core RestfulObjects Viewer Server
» [ specsupport [isis-core-specsupport] [ Isis Core Runtime
» Bsrc [ Isis Core Shiro Security
» Eltarget [ Isis Core Spec Support
» [ unittestsupport [isis-core-unittestsupport] [ Isis Core Unit Test Support
> O pplib [isi: i jt PPl ) Isis Core WebServer
[ -] g i [ Isis Core Wrapper Service
> [ 7 Isis Maven Plugin (isis-maven-plugin)
» [ viewer-wicket [isis-viewer-wicket] T Isis Wicket Viewer
» L2 webserver [isis-core-webserver] ) Isis Wicket Viewer Applib
» L& wrapper [isis-core-wrapper] 7 Isis Wicket Viewer Implementation
I isisiml 7 Isis Wicket Viewer Modlel
[El nomice ) Isis Wicket Viewer U Components
m pom.xml
[E) pom.mlversionsbackup
il External Libraries
]
*
087000  [H Terminal ™ Eventlog
Add and import Maven projects to the projects tree (e & [EEaEtasm]

Figure 21. IntelliJ Maven Module Management - Importing Maven modules

We can then import another module (from some other directory). For example, here we are

importing the Isis Addons' todoapp example:

AEIGEX O & Hide path
‘ CAGITHUB\isisaddons\isis-app-todoapp\pom.xml ||§
= [ bhargavgolla
[ chrissg
[ cucumber
[ danhaywood
[ datanucleus
[ detro
[ dileepajayakody
[ DimuthuUpe
[ estatio
[ geb
[ isisaddons [%

» [ isis-app-kitchensink
» [ isis-app-necapp
v [isis-app-todoapp
» dom
[ fisture

4 ¥ ¥ ¥ Y Y YVYVYY

[ images

[ integtests

[ logs

[ webapp

. S0 |
[ isis-jrebel-plugin

[ isis-metamodel-paranamesd

(3 isis-module-audit

[ isis-module-command

[ isis-module-devutils
Drag 2nd drop 2 fie into the space above to quickly Jocste tin the tree

o NEENRIETN

Figure 22. IntelliJ Maven Module Management - Importing another Module

You should then see the new Maven module loaded in the Projects window and also the

Maven

15



Projects window:

File Edit View Navigate Code Analyze Refactor Build Run Tools VCS Window Help

ODHO ¢4 X000 QR e« W@y B aPs 3 ?

A

Gk + PR*ES® S F
» [ Profiles

» [ Apache Isis Core (root)

» [ Isis Addons ToDoApp (root)

» [ Isis Addons ToDoApp DOM

» [ Isis Addons ToDoApp Fixtures

[ Isis Addons ToDoApp Integration Tests

#
L
pingi 3 | O

r-wicket and modules

is-core-applib]

r G 1 [isi

» Ealog4 [isis-core-logdjl

» B2 maven-plugin lisis-maven-plugin]
» [ metamodel [isis-core-metamodel]
» Earuntime [isis-core-runtime]

v

» [ Isis Addons ToDoApp Webapp

» [ Isis Core (Bypass) Security

» [ Isis Core AppLib

» [ Isis Core Integration Testing Support
» [ Isis Core Log4j Impls

» [ Isis Core MetaModel

» [ Isis Core RestfulObjects Viewer Applib
» [ Isis Core RestfulObjects Viewer Rendering
» [ Isis Core RestfulObjects Viewer Server
» [ Isis Care Runtime

» [ Isis Core Shiro Security

» [ Isis Core Spec Support

» [ Isis Core Unit Test Support

» [ Isis Core WebServer

» [ Isis Core Wrapper Service

» L3 security-noop [isis-core-security]

» [ security-shiro [isis-core-security-shiro]

» [ specsupport [isis-core-specsupport]

» E3 unittestsupport [isis-core-unittestsupport]
» L3 viewar- ppib [isi i jects-appl

» [Caviewer dlering [isi

» [Caviewer-r
» L2 webserver [isis-core-webserver]
[ wrapper [isis-core-wrapper]
v [itodo dules
» [3 dom [todoapp-dom]
» [ fiture [todoapp-fixture]
» L3 integtests [todoapp-integtests]
> Caisis-app-todoapp [todoapp] » [ Isis Maven Plugin (isis-maven-plugin)
b [ Isis Wicket Viewer
» [ Isis Wicket Viewer Applib
» [ Isis Wicket Viewer Implementation
» [ Isis Wicket Viewer Model
» [ Isis Wicket Viewer Ul Components

» [awebapp [todoapp-webapp]
» Hils External Libraries

Fl
*

W 57000 [E Terminal | version Control 1 EventLog
Frameworks detected: Wicket framework is detected in the project Configure (11 minutes aga) 51 Indexing... @ 5 Gmaster ¢ & 0 [isorasem]

Figure 23. IntelliJ Maven Module Management -

If any dependencies are already loaded in the project, then IntelliJ will automatically update the
CLASSPATH to resolve to locally held modules (rather from .m2/repository folder). So, for example
(assuming that the <version> is correct, of course), the Isis todoapp will have local dependencies on
the Apache Isis core.

You can press F4 (or use File > Project Structure ) to see the resolved classpath for any of the
modules loaded into the project.

If you want to focus on one set of code (eg the Isis todoapp but not Apache Isis core) then you could
remove the module; but better is to ignore those modules. This will remove from the the Projects
window but keep them available in the Maven Projects window for when you next want to work on
them:
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» [aisis-app-todoapp [todoapp]

» [dwebapp [todoapp-webapp]

» il External Libraries
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» T Apache Isis Core (roof) l?x” Reimport
» [ Isis Addons ToDoARP (/o5 iz Ganerate Sources and Update Folders
» [ Isis Addons ToDoApp DOM
» [ Isis Addons ToDoApp Fixtures.

— Remove Projects
» [ Isis Addons ToDoApp Integratic
» [ Isis Addons ToDoApp Webapp ~ OPen ‘settings.xml*
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™ Eventlog

Exclude/Include selected Maven projects from being imported

Figure 24. IntelliJ Maven Module Management - Ignoring Modules

Confirm that itOs ok to ignore these modules:

These modules have been removed from Maven structure:

Isis’

core-specsupport’

core-viewer-restfulobjects-applib’

core-metamodel’

core-viewer-restfulobjects-rendering’

maven-plugin’
core-webserver'
'Isis-viewer-wicket-impl'

‘Isis-viewer-wicket-applib'
'isis-core-integtestsupport!
‘isis-viewer-wicket-ui’
isis-core-security-shiro’
s-viewer-wicket-model

core-wrapper'

core-viewer-restfulobjects-server'

‘Isis-core-runtime’
isis-core-unittestsupport’

Figure 25. IntelliJ Maven Module Management - Ignoring Modules (ctd)

All being well you should see that the

on.
.m2/repository ):

/e |Gt master +| % 8 | erasm]

Projects window now only contains the code you are working
Its classpath dependencies will be adjusted (eg to resolve to Apache Isis core from
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